The STAQ UI is now loading across all customers
Major incident
STAQ UI
2024-05-23 19:14 UTC
· 4 hours, 4 minutes
Updates
Resolved
May 23, 2024 · 23:18 UTC
Issues with slow loading and failed responses have been resolved across all customer accounts.
Issue
May 23, 2024 · 19:14 UTC
We are seeing slow loading as well as some failed responses on the STAQ UI across a subset of customers. Engineering is actively investigating the issue and working towards resolution.
← Back