Potential Delays in Data Processing

Minor incident STAQ Report Processing
2025-02-07 22:36 UTC · 2 days, 17 hours, 58 minutes

Updates

Resolved

Data processing delays impacting a subset of customers are now resolved. We will continue to monitor.

February 10, 2025 · 16:32 UTC
Issue

Our team has detected delays in processing across a subset of accounts. This is currently under investigation.

February 7, 2025 · 22:36 UTC

← Back