Google Campaign Manager (DCM) Issues on Select Accounts
Minor incident
STAQ Data Ingestion
Google Campaign Manager
2025-04-03 14:32 UTC
· 1 hour, 33 minutes
Updates
Resolved
April 3, 2025 · 16:05 UTC
Impacted accounts are starting to collect data. We’ll be monitoring closely.
Issue
April 3, 2025 · 14:32 UTC
DCM is running into an error for a subset of accounts. This appears to be a Google side error. Our team has reached out to Google for additional investigation. We’ll be monitoring impacted accounts closely.
← Back