Outbound Scheduled Report Issues

Minor incident STAQ Data Pushes Scheduled Emails
2025-04-29 20:15 UTC · 18 hours, 54 minutes

Updates

Resolved

Scheduled Email delivery has been resolved. We will continue to monitor.

April 30, 2025 · 15:09 UTC
Issue

Scheduled Emails are currently not sending. This is under investigation.

April 29, 2025 · 20:15 UTC

← Back