Google Ad Manager (GAM) Version v202505 Upgrade from 2025-06-24 14:50 UTC to 2025-07-03 15:55 UTC

Scheduled maintenance STAQ Data Ingestion Google Ad Manager
2025-06-24 14:50 UTC · 1 week, 2 days, 1 hour, 5 minutes

Updates

Monitoring

Our team is working on updating the Google Ad Manager API to the newest available version v202505.

July 3, 2025 · 15:55 UTC
Monitoring

Our team is working on updating the Google Ad Manager API to the newest available version v202505.

June 24, 2025 · 14:50 UTC

← Back