STAQ Data Pushes
Major incident
STAQ Data Pushes
Scheduled Emails
Report Exports
2025-11-17 16:35 UTC
· 3 hours, 15 minutes
Updates
Resolved
November 17, 2025 · 19:50 UTC
This issue has been resolved and data pushes are functioning normally.
Issue
November 17, 2025 · 16:35 UTC
Data push delivery is currently impacted. Our engineering team is investigating the issue and working to restore normal service.
← Back
Platform Status