STAQ UI and processing is unavailable for a subset of clients
Minor incident
STAQ UI
STAQ Report Processing
2026-01-27 12:37 UTC
· 10 hours, 12 minutes
Updates
Resolved
January 27, 2026 · 22:46 UTC
Service has been fully restored. Our team will be monitoring closely.
Monitoring
January 27, 2026 · 12:37 UTC
We have resolved the underlying issue and are currently processing the backlog. All data should be fully updated shortly.
← Back
Platform Status