Collection Issues for Google Campaign Manager (DCM)

Minor incident STAQ Data Ingestion Google Campaign Manager
2026-05-21 15:49 UTC · 1 month, 2 weeks, 2 days, 3 hours, 55 minutes

Updates

Resolved

Following updates to the integration, collection stability has been restored. All missing May & June data has been successfully collected via the scheduled daily collections.

July 6, 2026 · 19:44 UTC
Monitoring

After in-depth investigation alongside the Google CM360 (DCM) team, updates have been made to stabilize the collections and successfully ingest missing data. The team is continuing to monitor daily collections, which are currently succeeding as expected

June 25, 2026 · 22:23 UTC
Issue

The Google Campaign Manager (DCM) API is experiencing intermittent collection failures. Our team is actively working to restore collections and ingest any missing data. We will provide updates as they become available.

May 21, 2026 · 15:49 UTC

← Back